Anybody met this issue of 'invalid pseudo-version'

root@skylon:~/gopath/src/github.com/filecoin-project/go-filecoin# FILECOIN_USE_PRECOMPILED_RUST_PROOFS=true go run ./build/*.go deps
go: github.com/go-critic/go-critic@v0.0.0-20181204210945-ee9bf5809ead: invalid pseudo-version: does not match version-control timestamp (2019-02-10T22:04:43Z)

Today, 2019-09-06, I git clone the newest code from GitHub, when executing the command as above, got this alarm info.

I haven’t seen this before. Did you run git submodule update --init --recursive before running deps?

I got the same error and I did run git submodule update --init —recursive first.

Was using go 1.13; switched to 1.12.9 and now it works.

1 Like