Apt-get cannot find many of the necessary install packages

I am attempting to set up the environment of prerequisites on a Ubuntu 20 Focal system. Apt is telling me there are no installation candidates for the following. They also did not exist for Ubuntu Bionicle so what am I missing or do the filecoin gods just not like me?

 mesa-opencl-icd ocl-icd-opencl-dev
bzr 
jq 
clang  
hwloc
 libhwloc-dev