Precommit phase 1 slower than expected

Hi,

Just getting my miner setup and precommit phase 1 is taking way longer than expected.

First my hardware setup:
Threadripper 3990x
128gb ram
Corsair force 1TB nvme ssd (boot drive, 250gb swap file)
Wd 10TB hdd

Running Ubuntu 20.04 server lts

So far it’s been running precommit phase 1 for 13h. It’s nearly done (generating layer 9 currently).

It looks like it should only take about 4 hours for this step according to these 2 links.

Any thoughts on why it’s so slow???
I had to move my params to the hdd as I didn’t have enough free space in the ssd, but that should only effect the miner/worker in startup right?

I ran cat /prod/cpuinfo and I can see 1 core hitting 4.2ghz so everything seems ok there…

Any thoughts or help is much appreciated!

Tried setting
FIL_PROOFS_USE_MULTICORE_SDR=1
As it says it speeds things up. Made sure to assign it to the first 4 cores of my CPU. Hopefully that makes the difference.

It’s strange talking to myself, but yes it makes all the difference. Finished precommit phase 1 in 4h instead of 14h!

西安灵动计算机系统有限公司在投资的“STCloud&Linden战队”,在Filecoin太空竞赛里获得了前三甲。

@lindenpool 恭喜你
@mnx Be sure you used RUSTFLAGS="-C target-cpu=native -g variable during software compilation.

@Rabinovitch Thanks, I did.

In my case setting FIL_PROOFS_USE_MULTICORE_SDR=1
sped up precommit phase 1 from taking 14h to only 4h, which is inline with all the benchmarks I saw.